Security upgrades and SPD hosted web sites …

Some customers may be unable to access SPD hosted websites due to security upgrades. Read more  

This is most likely to impact customers with Windows 7, or older devices that don't have TLS1.2 enabled by default.

For Windows 7 users, self-service instructions can be found here:

https://support.cybersource.com/s/article/How-do-I-enable-TLS-1-2-on-Windows-7

Impacted sites may include:

  • AASI
  • Advance Retail
  • Chris21
  • CMF Online
  • DocsOnline
  • eGiving
  • Events
  • Jasper
  • Knowledgebase
  • Membership Online
  • myAdventist portal
  • Tithes&Offerings

Image 01